"error: Failed dependencies" while installing MySQL 8.0+ RPM packages

(Doc ID 2391240.1)

Last updated on JUNE 27, 2018

Applies to:

MySQL Server - Version 8.0 and later
Information in this document applies to any platform.

Symptoms

When attempting to install MySQL 8.0+, it fails due to these dependencies:

 

Changes

The mysql-commercial-libs-compat package contains the MySQL 5.6 client libraries for backwards compatibility with applications that require earlier versions of libmysqlclient.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms