ORA-29400 - DG4MQ 11gR2 or 12c After MQ Client/Server Upgraded From V7 To V8 or V9.

(Doc ID 2409187.1)

Last updated on JUNE 20, 2018

Applies to:

Oracle Database Gateway for WebSphere MQ - Version 11.2.0.4 to 12.1.0.2 [Release 11.2 to 12.1]
Oracle Solaris on SPARC (64-bit)

Symptoms

When running Database Gateway for MQ Series (DG4MQ) 11gR2 or 12c after a MQ Client or Server upgrade from from v7 to v8 or V9, you encounter an ORA-29400 error.

The error in the IBM MQ Websphere client log is AMQ8597.

AMQ8597: This process is linked with an unsupported shared library.

EXPLANATION:
----------------------
A IBM MQ shared library '/opt/mqm/lib64/libmqmcs.so' was detected in this process before the first connection to a queue manager was made.

Linking applications to this shared library is not supported.

The application will fail with reason code MQRC_ENVIRONMENT_ERROR until the application has been re-linked without libmqmcs and libmqmzse.

ACTION:
------------
Re-link your application, omitting the -lmqmcs and -lmqmzse options from the command line.

This message can be suppressed by setting the AMQ_NO_MQMCS_MSG environment variable to any value.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms