'ORA-39142: incompatible version number 4.2' Error Seen When Importing A Dump File Generated With April 2018 DBBP

(Doc ID 2409523.1)

Last updated on JUNE 14, 2018

Applies to:

Oracle Database - Enterprise Edition - Version 12.1.0.2 to 12.1.0.2 [Release 12.1]
All Platforms

Symptoms

Import into a 12.1 database is failing with the below error:

Connected to: Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production
ORA-39001: invalid argument value
ORA-39000: bad dump file specification
ORA-39142: incompatible version number 4.2 in dump file "/dumpfile.dmp"

Source database version is 12.1.0.2 with 2018 April DBPB applied and the target version is 12.1.0.2 with a lower DBBP.

Extracting the dump file version using the script from <Document 462488.1> returns 4.2 version:

----------------------------------------------------------------------------
...Database Job Version..........: 12.01.00.02.00
...Internal Dump File Version....: 4.2

 Without 12.1.0.2.180417 Patch, the dump file version is 4.1:

----------------------------------------------------------------------------
...Database Job Version..........: 12.01.00.00.00
...Internal Dump File Version....: 4.1 (Oracle12c Release 1: 12.1.0.

 

Changes

April 2018 DBBP (Patch 27338029) applied in source database.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms