My Oracle Support Banner

Oracle PKI Tool(orapki) Version 11.1.1.9 Fails to Create/Convert an AES Encrypted Wallet with 'Invalid command: -compat_v12' (Doc ID 2416313.1)

Last updated on JUNE 27, 2018

Applies to:

Oracle Security Service - Version 11.1.1.9.0 to 11.1.1.9.0
Oracle HTTP Server - Version 11.1.1.9.0 to 11.1.1.9.0 [Release Oracle11g]
Information in this document applies to any platform.

Symptoms

When attempting to create or convert an AES encrypted wallet using Orapki Tool, the process fails with error 'Invalid command: -compat_v12.'

The documentation suggests this functionality exists.
Oracle Fusion Middleware Administrator's Guide
I Oracle Wallet Manager and orapki
I.2.4.1 Creating and Viewing Oracle Wallets with orapki

"
    To create an Oracle Wallet with AES Encryption:
    orapki wallet create -wallet wallet -pwd pwd -compat_v12
    This command creates an Oracle wallet with AES encryption.

    To convert an Existing Wallet to use AES Encryption:
    orapki wallet convert -wallet wallet -compat_v12 -pwd pwd
    This command converts an Oracle wallet from 3DES to AES encryption.
"

The error/output is as seen below:

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.