12.2 ACFS: failed to create acfs on 12.2 DG when the compatible.advm set to 12.2.0.1.0

(Doc ID 2416761.1)

Last updated on JUNE 29, 2018

Applies to:

Oracle Database - Enterprise Edition - Version 12.2.0.1 to 12.2.0.1 [Release 12.2]
Information in this document applies to any platform.

Symptoms

If you are trying to create an ACFS file system on disk group whose compatible.asm and compatible.advm are 12.2.0.1.0 with acfs compatibility 12.2

will be failed.

grid node1 /home/grid> mkfs -V acfs -o c=12.2 /dev/asm/racfsmnt04
mkfs: version = 12.2.0.1.0
mkfs: ACFS compatibility = 12.2.0.0.0
mkfs: ACFS-03697: The ACFS compatibility level must be set to 12.2.0.1.0 or
higher to proceed.
mkfs: ACFS-01004: /dev/asm/racfsmnt04 was not formatted.

grid node1 /home/ grid> mkfs -V acfs -o c=12.2.0.1.0 /dev/asm/racfsmnt04
mkfs: version = 12.2.0.1.0
mkfs: ACFS compatibility = 12.2.0.0.0
mkfs: ACFS-03697: The ACFS compatibility level must be set to 12.2.0.1.0 or
higher to proceed.
mkfs: ACFS-01004: /dev/asm/racfsmnt04 was not formatted.

ASMCMD> lsattr -G acfsdga1 -l %compatible%
Name Value
compatible.advm 12.2.0.1.0
compatible.asm 12.2.0.1.0
compatible.rdbms 12.2.0.0.0

ASMCMD> volinfo -G acfsdga1 acfsmnt04
Diskgroup Name: ACFSDGA1

Volume Name: ACFSMNT04
Volume Device: /dev/asm/racfsmnt04
State: ENABLED
Size (MB): 1024
Resize Unit (MB): 64
Redundancy: MIRROR
Stripe Columns: 8
Stripe Width (K): 1024
Usage:
Mountpath:

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms