My Oracle Support Banner

Preupgrade utility fails with error "SEVERE: ERROR - Cannot process preupgrade on the database.The database must be in any of the following modes:"READ WRITE or READ ONLY" (Doc ID 2438503.1)

Last updated on JULY 06, 2021

Applies to:

Oracle Database - Enterprise Edition - Version 12.2.0.1 to 18.3.0.0.0 [Release 12.2 to 18]
Information in this document applies to any platform.

Symptoms

1)While upgrading to 12.2,Pre-Upgrade,the following errors are seen -

oracle@xxxxxxx$ java -jar preupgrade.jar TEXT TERMINAL
ERROR - Cannot process preupgrade on the database
The database must be in any of the following modes:
"READ WRITE or READ ONLY"
If it is opened in READ ONLY mode then the DBMS_PREUP package must have been created before.
Also please keep in mind that the database must be exclusively in OPEN status.

 Following would be the error from DBUA-

DBUA trace.log contains the following lines-

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.