My Oracle Support Banner

12.2 Upgrade : Pre-Upgrade Fixup Script fails with error “rman_recovery_version Failed Manual fixup recommended” (Doc ID 2441660.1)

Last updated on APRIL 09, 2020

Applies to:

Oracle Database - Enterprise Edition - Version 12.2.0.1 and later
Information in this document applies to any platform.

Symptoms

 While upgrading to 12.2,the following message is displayed-

INFORMATION ONLY
================
+ Check the Oracle Backup and Recovery User’s Guide for information on how
to manage an RMAN recovery catalog schema.

If you are using a version of the recovery catalog schema that is older
than that required by the RMAN client version, then you must upgrade the
catalog schema.

It is good practice to have the catalog schema the same or higher
version than the RMAN client version you are using.

 If Pre-Upgrade Fixup Script is run,it errors out with the below message-

Executing Oracle PRE-Upgrade Fixup Script

Auto-Generated by: Oracle Preupgrade Script
Version: 12.2.0.1.0 Build: 15
Generated on: 2018-08-07 07:31:19

For Source Database: XXXX
Source Database Version: 12.1.0.2.0
For Upgrade to Version: 12.2.0.1.0

Executing in container: CDB$ROOT

Fixup
Check Name Status Further DBA Action
———- —— ——————
purge_recyclebin Passed None
rman_recovery_version Failed Manual fixup recommended. <<====

PL/SQL procedure successfully completed.

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.