My Oracle Support Banner

bdacheckcluster/bdachecksw Fail with "ERROR: Wrong puppet version x.y.z/ERROR: Required package puppet not found : package puppet is not installed" (Doc ID 2488820.1)

Last updated on JANUARY 10, 2020

Applies to:

Big Data Appliance Integrated Software - Version 4.5.0 and later
Linux x86-64

Symptoms

NOTE: In the examples that follow, user details, table name, company name, email, hostnames, etc. represent a fictitious sample (and are used to provide an illustrative example only). Any similarity to actual persons, or entities, living or dead, is purely coincidental and not intended in any manner.

Running bdacheckluster/bdachecksw fails with puppet version errors like below on one, or more, cluster nodes.

Incorrect output looks shows a message similar to below (where x.y.z indicates an incorrect puppet version):

  

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
 On Node 1
 On Each Node with Puppet Errors
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.