My Oracle Support Banner

OPATCH ON AIX FAILS WITH ERRORS 0509-022 AND 0509-026 FOR THE FILE LIBORAINSTALLER.SO (Doc ID 2544549.1)

Last updated on OCTOBER 31, 2019

Applies to:

Oracle Database - Enterprise Edition - Version 12.1.0.2 and later
Information in this document applies to any platform.

Symptoms

OPatch command on AIX platform fails with below error.

OPatch command on AIX platform fails with below error.

$opatch lsinventory
java.lang.UnsatisfiedLinkError: /u01/app/oracle/product/12.1.0/oui/lib/aix/liboraInstaller.so ( 0509-022 Cannot load module /u01/app/oracle/product/12.1.0/oui/lib/aix/liboraInstaller.so.
0509-026 System error: Cannot run a file that does not have a valid format.)
at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:1344)
at java.lang.System.load(System.java:539)
at oracle.sysman.oii.oiip.osd.unix.OiipuUnixOps.loadNativeLib(OiipuUnixOps.java:364)
at oracle.sysman.oii.oiip.osd.unix.OiipuUnixOps.<clinit>(OiipuUnixOps.java:128)
at oracle.sysman.oii.oiip.oiipg.OiipgEnvironment.ssgetUidux(OiipgEnvironment.java:528)
at oracle.sysman.oii.oiix.OiixEnvironmentOps.ssgetUidux(OiixEnvironmentOps.java:159)
at oracle.opatch.OUIReplacer.isRootAccess(OUIReplacer.java:624)
at oracle.opatch.OPatch.process(OPatch.java:574)
at oracle.opatch.OPatch.main(OPatch.java:834)

 

Changes

 Updated OPatch Version

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.