My Oracle Support Banner

How to Execute create-PrepatchReport To Avoid "odacli: 'create-prepatchreport' is not an odacli command" (Doc ID 2585451.1)

Last updated on JUNE 26, 2020

Applies to:

Oracle Database Appliance Software - Version 12.2.1.2.0 to 18.3.0.0.0 ODAVP [Release 12.2]
Information in this document applies to any platform.

Goal

On : Oracle Database Appliance (12.2.1.2)

Getting an error when running odacli create-prepatchreport

When running the above command, I get the following error,

  "odacli: 'create-prepatchreport' is not an odacli command".

When I do a "odacli -h", it doesn't list "create-prepatchreport" or "describe-prepatchreport" as an option.

Is there anyway to just update the odacli version? Can I just copy the one that works on our other ODA to this one? Below is the version listing of our system.

System Version
---------------
12.2.1.2.0

Component Installed Version Available Version
---------------------------------------- -------------------- --------------------
OAK 12.2.1.2.0 up-to-date
GI 12.2.0.1.171017 up-to-date
DB {
[ OraDB12201_home1 ] 12.2.0.1.171017 up-to-date
[ OraDB12102_home1 ] 12.1.0.2.171017 up-to-date
}
DCSAGENT 12.2.1.2.0 up-to-date
ILOM 4.0.0.28.r121827 4.0.0.22.r120818
BIOS 41017600 41017100
OS 6.8 up-to-date
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.