My Oracle Support Banner

GI upgrade from 12.1.0.2 To 19.5 fails with the error "PRCR-1209 : failed to upgrade the dependencies for resource ora.nfs_havip_id.havip (Doc ID 2645603.1)

Last updated on MARCH 04, 2020

Applies to:

Oracle Database - Enterprise Edition - Version 19.5.0.0.0 and later
Information in this document applies to any platform.

Symptoms

GI upgrade from 12.1.0.2 to 19.5 fails with the below error in the first node .

rootupgrade.sh script getting following error:

2019/12/10 13:41:22 CLSRSC-595: Executing upgrade step 1 of 18: 'UpgradeTFA'.
2019/12/10 13:41:22 CLSRSC-4015: Performing install or upgrade action for Oracle Trace File Analyzer (TFA) Collector.
2019/12/10 13:41:23 CLSRSC-595: Executing upgrade step 2 of 18: 'ValidateEnv'.
2019/12/10 13:41:27 CLSRSC-595: Executing upgrade step 3 of 18: 'GetOldConfig'.
2019/12/10 13:41:27 CLSRSC-464: Starting retrieval of the cluster configuration data
2019/12/10 13:43:19 CLSRSC-4003: Successfully patched Oracle Trace File Analyzer (TFA) Collector.
2019/12/10 13:45:16 CLSRSC-692: Checking whether CRS entities are ready for upgrade. This operation may take a few minutes.
PRCR-1209 : failed to upgrade the dependencies for resource ora.nfs_havip_id.havip<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
PRCR-1209 : failed to upgrade the dependencies for resource ora.nfs_havip_id.havip
2019/12/10 13:46:49 CLSRSC-180: An error occurred while executing the command '/<19c_GI_HOME>/bin/srvctl upgrade model -s 12.1.0.2.0 -d 19.0.0.0.0 -p first'
2019/12/10 13:46:53 CLSRSC-694: failed to validate CRS entities for upgrade, aborting the upgrade
2019/12/10 13:46:53 CLSRSC-362: The pre-upgrade checks failed, aborting the upgrade
Died at /<19c_GI_HOME>c/crs/install/crsupgrade.pm line 3772.

 

+From rootupgrade log:

++++++++++++

2019-12-10 13:46:08: Invoking "/<19c_GI_HOME>/bin/srvctl upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first"
2019-12-10 13:46:08: trace file=/opt/oracle/app/oracle/crsdata/cmsbuat1/crsconfig/srvmcfg1.log
2019-12-10 13:46:08: Executing cmd: /<19c_GI_HOME>/bin/srvctl upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first
2019-12-10 13:46:49: Command output:
>  PRCR-1209 : failed to upgrade the dependencies for resource ora.nfs_havip_id.havip<<<<<<<<<<<<<<<<<<<<<<<PRCR-1209
>  PRCR-1209 : failed to upgrade the dependencies for resource ora.nfs_havip_id.havip
>End Command output
2019-12-10 13:46:49:  "upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first" failed with status 1.
2019-12-10 13:46:49: Executing cmd: /<19c_GI_HOME>/bin/clsecho -p has -f clsrsc -m 180 '/<19c_GI_HOME>/bin/srvctl upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first'
2019-12-10 13:46:49: Executing cmd: /<19c_GI_HOME>/bin/clsecho -p has -f clsrsc -m 180 '/<19c_GI_HOME>/bin/srvctl upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first'
2019-12-10 13:46:50: Command output:
>  CLSRSC-180: An error occurred while executing the command '/opt/oracle/app/grid/19c/bin/srvctl upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first'
>End Command output
2019-12-10 13:46:50: CLSRSC-180: An error occurred while executing the command '/<19c_GI_HOME>/bin/srvctl upgrade model  -s 12.1.0.2.0 -d 19.0.0.0.0 -p first'
2019-12-10 13:46:50: Dry run...first node upgrade model failed
2019-12-10 13:46:50: Executing cmd: /<19c_GI_HOME>/bin/crsctl sandbox clean
2019-12-10 13:46:53: crsctl sandbox clean output =
2019-12-10 13:46:53: Upgrade dry run failed
2019-12-10 13:46:53: Executing cmd: /<19c_GI_HOME>/bin/clsecho -p has -f clsrsc -m 694
2019-12-10 13:46:53: Executing cmd: /<19c_GI_HOME>/bin/clsecho -p has -f clsrsc -m 694
2019-12-10 13:46:53: Command output:
>  CLSRSC-694: failed to validate CRS entities for upgrade, aborting the upgrade
>End Command output
2019-12-10 13:46:53: CLSRSC-694: failed to validate CRS entities for upgrade, aborting the upgrade
2019-12-10 13:46:53: Executing cmd: /<19c_GI_HOME>/bin/clsecho -p has -f clsrsc -m 362
2019-12-10 13:46:53: Executing cmd: /<19c_GI_HOME>/bin/clsecho -p has -f clsrsc -m 362
2019-12-10 13:46:54: Command output:
>  CLSRSC-362: The pre-upgrade checks failed, aborting the upgrade
>End Command output
2019-12-10 13:46:54: CLSRSC-362: The pre-upgrade checks failed, aborting the upgrade
2019-12-10 13:46:54: ###### Begin DIE Stack Trace ######
2019-12-10 13:46:54:     Package         File                 Line Calling  
2019-12-10 13:46:54:     --------------- -------------------- ---- ----------
2019-12-10 13:46:54:  1: main            rootcrs.pl            355 crsutils::dietrap
2019-12-10 13:46:54:  2: crsupgrade      crsupgrade.pm        3772 main::__ANON__
2019-12-10 13:46:54:  3: crsupgrade      crsupgrade.pm        1883 crsupgrade::upgrade_dry_run
2019-12-10 13:46:54:  4: crsupgrade      crsupgrade.pm        1079 crsupgrade::get_oldconfig_info
2019-12-10 13:46:54:  5: crsupgrade      crsupgrade.pm         603 crsupgrade::CRSUpgrade
2019-12-10 13:46:54:  6: main            rootcrs.pl            364 crsupgrade::new
2019-12-10 13:46:54: ####### End DIE Stack Trace #######

 

The above issue occurs even in the upgrade dry run also.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.