My Oracle Support Banner

Opatch fails with Error 'Java (1.7) could not be located. OPatch cannot proceed!' (Doc ID 2741131.1)

Last updated on JUNE 24, 2021

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.4 and later
IBM AIX on POWER Systems (64-bit)

Symptoms

 Opatch utility fails with below error for 11.2.0.4 home -

$ opatch version
Java (1.7) could not be located. OPatch cannot proceed!
OPatch returns with error code = 1

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.