My Oracle Support Banner

OPatch lsinventory or Apply New Patch With Opatch apply Fails With Error "Unable to create patchObject" Inventory Corrupted (Doc ID 2792549.1)

Last updated on DECEMBER 02, 2021

Applies to:

Oracle Database - Enterprise Edition - Version 19.3.0.0.0 and later
Information in this document applies to any platform.

Symptoms

oracle rac node2 not able to patch to 19.11 - OPatch failed with error code 73

Applying patch 32545013 (DATABASE RELEASE UPDATE 19.11.0.0.0 ) in 2 Node RAC environment

Opatch apply was successful on host1.

Opatch apply on Hostname2 fails with below errors:

[INFO]   Unable to create patchObject
Possible causes are:
                                      ORACLE_HOME/inventory/oneoffs/32545013 is corrupted. PatchObject constructor: Input file "$ORACLE_HOME/inventory/oneoffs/32545013/etc/config/actions" or "$ORACLE_HOME/inventory/oneoffs/32545013/etc/config/inventory" does not exist.
[SEVERE] OUI-67073:UtilSession failed: NApply was not able to get the list of patches to apply

Changes

 Application o April 2021 RU on RAC environment.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.