My Oracle Support Banner

Firmware not updated during re-image/provisioning of Oracle Database Appliance (ODA) 19.10 (Doc ID 2805553.1)

Last updated on DECEMBER 01, 2021

Applies to:

Oracle Database Appliance Software - Version 19.10.0.0.0 ODA to 19.10.0.0.0 ODA [Release 19]
Information in this document applies to any platform.

Symptoms

Re-imaged an Oracle Database Appliance (ODA) X7-2 HA to ODA software version 19.10.
BIOS, ILOM and Firmware did not update.

Attempted to run odacli update-storage -v 19.10.0.0.0 and it failed.

[root@node1 ~]# /opt/oracle/dcs/bin/odacli describe-component

System Version
---------------
19.10.0.0.0

System node Name
---------------
node1

Local System Version
---------------
19.10.0.0.0

Component Installed Version Available Version
---------------------------------------- -------------------- --------------------
OAK 19.10.0.0.0 up-to-date

GI 19.10.0.0.210119 up-to-date

DB {
[ OraDB12102_home4 ] 12.1.0.2.210119 up-to-date
[ OraDB19000_home1 ] 19.10.0.0.210119 up-to-date
}

DCSAGENT 19.10.0.0.0 up-to-date

OS-7.9 up-to-date

ILOM 5.0.1.21.a.r138015 up-to-date

BIOS 41080800 up-to-date

FIRMWARECONTROLLER 13.00.00.00 16.00.08.00

FIRMWAREEXPANDER 0309 0310

FIRMWAREDISK {
[ c0d0,c0d1 ] 0112 up-to-date
[ c1d0,c1d1,c1d2,c1d3,c1d4,c1d5,c1d6, A122 A170
c1d7,c1d8,c1d9,c1d10,c1d11,c1d12,c1d13,
c2d0,c2d1,c2d2,c2d3,c2d4,c2d5,c2d6,c2d7,
c2d8,c2d9,c2d10,c2d11,c2d12,c2d13 ]
}

ASR 20.3.0 up-to-date

@ HMP 2.4.7.0.1 up-to-date

System node Name
---------------
node2

Local System Version
---------------
19.10.0.0.0

Component Installed Version Available Version
---------------------------------------- -------------------- -------------------
OAK 19.10.0.0.0 up-to-date

GI 19.10.0.0.210119 up-to-date

DB {
[ OraDB12102_home4 ] 12.1.0.2.210119 up-to-date
[ OraDB19000_home1 ] 19.10.0.0.210119 up-to-date
}
DCSAGENT 19.10.0.0.0 up-to-date

OS-7.9 up-to-date

ILOM 5.0.1.21.a.r138015 up-to-date

BIOS 41080800 up-to-date

FIRMWARECONTROLLER 13.00.00.00 16.00.08.00

FIRMWAREEXPANDER 0309 0310

FIRMWAREDISK {
[ c0d0,c0d1 ] 0112 up-to-date
[ c1d0,c1d1,c1d2,c1d3,c1d4,c1d5,c1d6, A122 A170
c1d7,c1d8,c1d9,c1d10,c1d11,c1d12,c1d13,
c2d0,c2d1,c2d2,c2d3,c2d4,c2d5,c2d6,c2d7,
c2d8,c2d9,c2d10,c2d11,c2d12,c2d13 ]
}

HMP 2.4.7.0.1 up-to-date

Attempted to run odacli update-storage -v 19.10.0.0.0 and it failed.
[root@bosmdb1 ~]# /opt/oracle/dcs/bin/odacli update-storage -v 19.10.0.0.0
DCS-10200:Supplied version: 19.10.0.0.0 is invalid.

Next, attmepted to run odacli-update repository again using the
instructions from the provisioning (not the patching). After dong this, still get the
error -

odacli update-storage -v 19.10.0.0.0
DCS-10200:Supplied version: 19.10.0.0.0 is invalid.

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.