My Oracle Support Banner

19c:Database upgrade fails with Error:"[DBT-20021] The current Oracle home <19c ORACLE_HOME> does not have the required Enterprise licence to perform the database upgrade operation." (Doc ID 2832818.1)

Last updated on JANUARY 11, 2022

Applies to:

Oracle Database - Enterprise Edition - Version 19.13.0.0.0 and later
Information in this document applies to any platform.

Symptoms

DBUA upgrade to Oracle 19c, fails with error:

[DBT-20021] The current Oracle home <19c ORACLE_HOME> does not have the required Enterprise licence to perform the database upgrade operation.

trace.log<timestamp> shows:

pool-1-thread-1] [ 2021-12-06 16:34:32.714 CST ] [OracleHome.getVersion:1134] Current Version From Inventory: 19.0.0.0.0
SEVERE: Dec 06, 2021 4:34:32 PM oracle.install.commons.util.exception.AbstractErrorAdvisor getDetailedMessage
SEVERE: [FATAL] [DBT-20021] The current Oracle home<19c ORACLE_HOME> does not have the required Enterprise licence to perform the database upgrade operation.

SEVERE: Dec 06, 2021 4:34:32 PM oracle.assistants.common.base.util.AssistantAdvisor logMessage
SEVERE: [ 2021-12-06 16:34:32.716 CST ] [FATAL] [DBT-20021] The current Oracle home <19c ORACLE_HOME> does not have the required Enterprise licence to perform the database upgrade operation.

INFO: Dec 06, 2021 4:59:23 PM oracle.install.commons.util.exception.AbstractErrorAdvisor advise
INFO: Advice is ABORT

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.