My Oracle Support Banner

Problem With API (ORDS) Integration Database 19c And MongoDB (Doc ID 3007531.1)

Last updated on MAY 16, 2024

Applies to:

Oracle Database - Enterprise Edition - Version 19.20.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Attempting to integrate MongoDB with Oracle Database using the following blog:
https://blogs.oracle.com/database/post/installing-database-api-for-mongodb-for-any-oracle-database

After integrating the API with ORDS with Instance Oracle Database 19c and MongoDB 5.X, the following error occurs when connecting with MongoCompass:

"Oracle Database version 21c or later is required".

The blog indicates the following as prerequisites:

1. Any Oracle Database 21c (or 23ai when available)
2. Any Autonomous Database, including ADB Serverless, ADB-Dedicated and ADB on Exadata Cloud@Customer, which all run Oracle Database 19c.
3. Possibly any Oracle Database 19c with a very recent patch set, but for that you need to talk to us ...

For point 3, is there a patch to resolve this error?

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.