My Oracle Support Banner

Wrong Version in DBA_REGISTRY after applying Patchset 9.2.0.6 (Doc ID 313537.1)

Last updated on APRIL 13, 2020

Applies to:

Operating System Dependent Interface - Version 9.2.0.6 and later
IBM z/OS on System z
***Checked for relevance on 14-Dec-2011***


Symptoms

During upgrade from V9205 to V9206 versions of components in dba_registry are not upgraded after execution of catpatch script.
Query  select comp_name,version,status from dba_registry shows components versions and status for each component:

COMP_NAME                      VERSION                        STATUS
------------------------------ ------------------------------ -----------
Oracle9i Catalog Views         9.2.0.6.0                      VALID
Oracle9i Packages and Types    9.2.0.6.0                      INVALID
JServer JAVA Virtual Machine   9.2.0.5.0                      VALID


Oracle9i Java Packages         9.2.0.5.0                      VALID
Oracle XDK for Java            9.2.0.7.0                      VALID
Spatial                        9.2.0.5.0                      VALID
Oracle Text                    9.2.0.5.0                      VALID

Also the following errors are displayed in catpacth execution spool:

BEGIN dbms_registry_sys.validate_components; END;

ERROR at line 1:
ORA-06550: line 1, column 25:
PLS-00302: component 'VALIDATE_COMPONENTS' must be declared
ORA-06550: line 1, column 7:
PL/SQL: Statement ignored

 

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.