Sqlcode -20210 When Using 10.2.0.2 Tg4db2 and DB2 v8

(Doc ID 392165.1)

Last updated on APRIL 13, 2007

Applies to:

Oracle Transparent Gateway for DB2 - Version: 10.2.0.2
IBM z/OS (OS/390)

Symptoms

Problem occured when the Oracle Transparent Gateway for DB2 was upgraded to 10.2.0.2 and accessing
DB2 v8.
The eeror below was encountered:

ERROR at line 1:
ORA-28500: connection from ORACLE to a non-Oracle system returned this message:
DSNT408I SQLCODE = -20210, ERROR: THE SQL STATEMENT CANNOT BE EXECUTED BECAUSE
IT WAS PRECOMPILED AT A LEVEL THAT IS INCOMPATIBLE WITH THE CURRENT
VALUE OF THE ENCODING BIND OPTION OR SPECIAL REGISTER
DSNT418I SQLSTATE = 560B8 SQLSTATE RETURN CODE
DSNT415I SQLERRP = DSNXEDP SQL PROCEDURE DETECTING ERROR
DSNT416I SQLERRD = -650 0 0 -1 0 0 SQL DIAGNOSTIC INFORMATION
DSNT416I SQLERRD = X'FFFFFD76' X'00000000' X'00000000' X'FFFFFFFF'
X'00000000' X'00000000' SQL DIAGNOSTIC INFORMATION
ORA-02063: preceding 9 lines from OR_DBX1

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms