How to Allow Login to Database Based on the Client Version (Doc ID 402193.1)

Last updated on OCTOBER 27, 2016

Applies to:

Oracle Net Services - Version 10.1.0.2 to 12.1.0.2 [Release 10.1 to 12.1]
Information in this document applies to any platform.

Goal

This note is intended to show how to define the minimum version of Oracle client that would be allowed to connect to your database.  It is possible to restrict access to the database by specifying the minimum version allowed.  If a client does not meet or exceed the version specified, the client connection will be rejected with an ORA-28040 error.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms