DBSTART script reports Warning: Version 10 listener is required for Oracle Database 10g (Doc ID 549172.1)

Last updated on OCTOBER 27, 2016

Applies to:

Oracle Net Services - Version 10.2.0.1.0 to 11.2.0.4 [Release 10.2 to 11.2]
Information in this document applies to any platform.
This problem can occur on any platform.

Symptoms

DBSTART script provided for Oracle Versions 10.2.0.1 onwards for UNIX systems is incorrect.It falsely reports that the listener version is not valid: Following messages are sent to user 'root':

"Warning: Version 10 listener is required for Oracle Database 10g" 
"Version $VER10LIST for Listener is NOT supported with Database version $VER10INST" 
"Restart Oracle Net Listener using an alternate ORACLE_HOME_LISTNER: lsnrctl start" 

Listener control command, lsnrctl version shows the correct version for the listener control.

 

In Oracle 11.2.0.4, the dbstart script reports:

  However this warning does not stop the dbstart script from starting up the database successfully.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms