UTL_HTTP ORA-28860 After Upgrading From 11.1.0.6 To 11.1.0.7 Database (Doc ID 760846.1)

Last updated on JULY 05, 2017

Applies to:

PL/SQL - Version 11.1.0.7 and later
Information in this document applies to any platform.
PL/SQL - Version: 11.1.0.7
This problem can occur on any platform.
UTL_HTTP

*** Checked for relevance on 06-Jul-2017 ***

Symptoms

After applying Oracle 11.1.0.7.0 patchset on existing Oracle 11.1.0.6.0, applications using UTL_HTTP over SSL/WALLETS fails with ORA-28860.

Changes

Before installation of the Oracle 11g Patchset 11.1.0.7, the following code worked fine:

declare
  req utl_http.req;
begin
  utl_http.set_wallet ('file:/oracle/app/oracle/wallet/test','password'); 
  req := utl_http.begin_request(url => 'https://xml-test.rdw.nl/start.test' 
                                      , method => 'POST' 
                                      , http_version => 'HTTP/1.1');
end;
/


The same wallet file was used after upgrading to 11.1.0.7.

No other changes were made to the system, only the patchset can have influenced the outcome.  The exact same application used to work fine in Oracle 11g  patchset 11.1.0.6.0.

Errors after upgrading to 11.1.0.7:

declare
*
ERROR at line 1:
ORA-29273: HTTP request failed
ORA-06512: at "SYS.UTL_HTTP", line 1029
ORA-28860: Fatal SSL error
ORA-06512: at line 5

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms