How to Setup DG4DRDA (Oracle Database Gateway for DRDA) Release 11.2 or 12c on 64bit Unix (Linux, AIX, HP-UX Itanium and Solaris) to Connect to DB2 (Doc ID 945879.1)

Last updated on OCTOBER 15, 2016

Applies to:

Oracle Database Gateway for DRDA - Version 11.2.0.0 and later
IBM AIX on POWER Systems (64-bit)
Oracle Solaris on SPARC (64-bit)
HP-UX Itanium
Linux x86-64

Goal

Starting with 11.2 Oracle released a complete new DRDA gateway containing features of the old DRDA gateway release up to 11.1, of the TG4DB2/400 gateway and the Mainframe gateway TG4DB2.

The DRDA gateway release 11.2 is certified with Oracle database release 10.1.0.5, 10.2.0.3 after applying the gateway compatibility patch <bug 5965763> or you can directly use it with Oracle RDBMS 10.2.0.4, 10.2.0.5, 11.1  and 11.2.  It might work with 9.2.0.8 after applying patch <bug 5965763> but there's no guarantee as the 11.2 gateway was never officially certified with 9.2.0.8 Oracle database release.

The DRDA gateway 12c is certified with Oracle database release 12.1, 11.2 and 11.1.

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms