Unable to Start Weblogic After Upgrading From 6.x to 6.2 - java.lang.NoClassDefFoundError: weblogic/Server (Doc ID 1279026.1)

Last updated on NOVEMBER 22, 2016

Applies to:

Oracle Transportation Management - Version 6.0 to 6.2.0 [Release 6 to 6.2]
Information in this document applies to any platform.
***Checked for relevance on 13-Jan-2014***

Symptoms

After upgrading from OTM 6.x to 6.2 some users have reported problems starting Weblogic on the Application Server.

The console logs for Weblogic may show the following error.

INFO | 2010/12/10 14:45:49 | Exception in thread "Main Thread" java.lang.NoClassDefFoundError: weblogic/Server
INFO | 2010/12/10 14:45:49 | Caused by: java.lang.ClassNotFoundException: weblogic.Server
INFO | 2010/12/10 14:45:49 | at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
INFO | 2010/12/10 14:45:49 | at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
INFO | 2010/12/10 14:45:49 | at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
INFO | 2010/12/10 14:45:49 | at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
INFO | 2010/12/10 14:45:49 | at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
INFO | 2010/12/10 14:45:49 | Could not find the main class: weblogic.Server. Program will exit

 

Changes

Updating OTM 6.0 or 6.1 to OTM 6.2.

Note: During this process Weblogic will be upgraded from 9.2.3 or 10.3.1.0 to 10.3.3.0. The version you are updating from depends on what version of OTM you were running before running the 6.2 update.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms