Attribute Values not seen when attribute group is selected from the LOV in the Asset Attributes Form when "Context Name" is different from "context Code" in the DFF setup of the "Asset Attributes" (Doc ID 1335670.1)

Last updated on OCTOBER 28, 2016

Applies to:

Oracle Enterprise Asset Management - Version 12.1.3 and later
Information in this document applies to any platform.
***Checked for relevance on 20-Dec-2012***

Symptoms

On : 12.1.3 version, Asset Definition

Attribute Values are not seen when attribute group is selected from the LOV in the Asset Attributes Form.
This happens only in the case of the "Context Name" is different from "context Code" in the DFF setup of the "Asset Attributes".


The issue can be reproduced at will with the following steps:
1) select Attribute Group from LOV (selection depends on Attribute Assignments)
2) new window opens with one field Context Value where we must choose again from LOV but now it retrieves all possible context values regardless what we defined in Attribute Assignments. On 12.1.2 this step already showed all the segments/attribute values from context chosen in step 1)
3) after populating values and saving we can see normally context and by clicking in the Attribute Value field also segments.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms