My Oracle Support Banner

iSupport Subscriptions Not Sending Emails (Doc ID 1463016.1)

Last updated on JULY 21, 2020

Applies to:

Oracle iSupport - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

After the running of Concurrent Request IBU_PRODUCT_EMGEN, no emails are generated.
This is happening since the upgrade to Release 12.

Error

Concurrent log shows errors like the ones below:

Frequency[MONTH] Subscription users found = 13
------------------------------------------
user Id : 22760244411
Error processing subscription for user [22760244411]Error getting WF Directory Info for role [IBU_ROLE22760244411]: Null email address found for role [IBU_ROLE22760244411]
[...]

Frequency[WEEK] Subscription users found = 26
------------------------------------------
user Id : 42332374455
Error processing subscription for user [42332374455]Error getting WF Directory Info for role [IBU_ROLE42332374455]: Null email address found for role [IBU_ROLE42332374455]
[...]

Steps to Reproduce

(R) iSupport Administrator - JTF Administration
(N) Profile link > Support (ibuprofgeneral.jsp)
   - Email Subscription information is shown

Then run the Concurrent Program IBU_PRODUCT_EMGEN.
=> The log shows errors.

What is Working

In 11i we have subscriptions being sent out without any issues.

File Version

oracle.apps.ibu.homepage.EmailConcProgram
EmailConcProgram.java 120.7.12010000.2 2010/01/13 11:36:38 mkundali ship $

Changes

 Upgrade to 12.1.3.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.