Customers Workbench: Error While Inactivating a Customer: "This Usage Assignment Does Not Exist" (Doc ID 1516359.1)

Last updated on OCTOBER 15, 2016

Applies to:

Oracle Receivables - Version 12.1.1 and later
Information in this document applies to any platform.

Symptoms

Attempting to Inactivate a Customer and receive the following error:

ERROR
-----------------------
Usage Assignment does not exist


Steps to Reproduce:
Responsibility:  Receivables
Navigation:  Customers > Customers
1. Open a Customer account details
2. Inactivate the customer from the customer screen.
3. Re-activate the same customer via Customer Interface.
4. Attempt to inactivate the same customer from the Customers screen.
5. This error message is received: "Usage Assignment does not exist"

The reason for this is because in the hz_party_usg_assignments table, there is no active record for the party.
When users first create a customer (step a above) using RACUST, it is creating a record in this table.
In Step 2 above, it is end dating this record when user is inactivating the customer.
But in Step 3, when updating the customer using RACUST, it is not creating a new record in this hz_party_usg_assignments table.

If using the TCA API's in place of Customer Interface, there is no issue.

This issue is only happening because when updating the customer record through the Customer Interface program, it is not creating a record in the hz_party_usg_assignments table.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms