Depot Repair: Adding Material Requirement Fails With Required Field (wip_supply_type) Is Missing (Doc ID 1623962.1)

Last updated on SEPTEMBER 06, 2016

Applies to:

Oracle Depot Repair - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

On :  12.1.3 version, Estimate and Actual Charges

When attempting to add a material requirement line to a depot repair job through the technician portal and the item is the same as the item on the previous line (but a different operation), the following error occurs.

ERROR
-----------------------
Error
  4439591 : Required field (wip_supply_type) is missing.
  VALIDATION ERROR HAPPENED!
  Adding the selected Materials to the selected Jobs has failed. Please check the 'Pending Jobs and Schedules' form to view the errors.


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. create a repair order with a wip job (using a routing that has multiple operations)
2. open technician portal
3. on the execution tab, add a requirement line for item A, operation 10
4. add a requirement line for item B, operation 10
5. add a requirement line for item B, operation 20
   --> this fails as reported
6. add a requirement line for item A, operation 20 --> ok
7. add a requirement line for item B, operation 20 --> now it does not fail

the error comes up when the item for the new item is the same as the last one displayed before it - the page orders them in it's own way so the steps above may vary.



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms