Transit time is not calculated on order line instantaneously for newly created sites in Sales Order form (Doc ID 1626144.1)

Last updated on JULY 19, 2016

Applies to:

Oracle Shipping Execution - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

On : 12.1.3 version, ATP based on collected data

ACTUAL BEHAVIOR
---------------
Transit time for newly created sites does not update immediately on Sales Order form using region functionality for transit time calculation.

This works fine when the sites are created via customer master. But when the sites are created via Order entry form itself, it takes some time for ATP to recognize the transit time. customer get orders via EDI and they are created with transit time as 0, even though there is a transit time defined for the zone.

EXPECTED BEHAVIOR
-----------------------
Transit lead time should be considered

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Defined a region XX, with transit time of 1 day and a default ship method.
2. Collections have been run and all existing ship-to sites with country XX have a transit time of 0.
3. Created a new address on the fly using Order Organizer form, and expect the transit time to be taken into account.
4. For first few lines it ignores the transit time (it's seems like there is a time lag between entering address and ATP associating it to the region) and then it starts behaving as expected.

BUSINESS IMPACT
-----------------------
The orders will be scheduled with incorrect transit times

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms