Upgrade to Latest JDK 7.0 Fails With Error "OPatch Failed During Prerequisite Check"

(Doc ID 1644495.1)

Last updated on OCTOBER 31, 2016

Applies to:

Oracle Applications Technology Stack - Version 12.1.2 and later
Information in this document applies to any platform.

Symptoms

On : 12.1.2 version, Forms/iAS/Database patching issues

Upgrade to latest JDK 7.0 on Application tier nodes by following Doc ID 1467892.1 fails with the following error:

ERROR
-----------------------
Error in executing Java program to check conflict

ERROR: OPatch failed during prerequisite check.

Changes

JDK 7.0 upgrade.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms