UPK: Publishing Fails with Prefix 'w15' is not defined After Modifying Template with Word 2013 (Doc ID 1667456.1)

Last updated on SEPTEMBER 01, 2015

Applies to:

User Productivity Kit - Version 11.1.0.1 to 11.1.0.2 [Release 11.1]
Information in this document applies to any platform.

Symptoms


After editing a printtemplate (SPD) with MS Word 2013 publishing fails with the following errors:


ERROR
-----------------------

Errors can appear in publishing log like this after editing the PrintTemplate.docm by Word 2013:
odpub://int/SPD/OxmlPrint/Unpacked/word/settings.xml  Prefix 'w15' is not defined.  -1673847682
odpub://int/SPD/OxmlPrint/Temp/XXX_SPD.docx  Input file is corrupted : 'odpub://int/SPD/OxmlPrint/Temp/XXX_SPD.docx'  -102176231



STEPS
-----------------------
The issue can be reproduced at will with the following steps:

1. Publish a topic (i.e., recording) using the UPK standard SPD template. Publish completes.
2. Access the English Language SPD publishing template (Word doc) in the Library.
3. Open the template in MS Word 2013, and make a change (e.g., change the header, change the font type).
4. Save the changes to the publishing template.
5. Select a topic in Library, using the custom/modified SPD template. Publish fails with the activity log.



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms