"JSR 356 WebSocket (Java WebSocket 1.0)" Message Starting Webservice for OTM (Doc ID 1931879.1)

Last updated on OCTOBER 02, 2014

Applies to:

Oracle Transportation Management - Version 6.3.3 to 6.3.5 [Release 6.3]
Information in this document applies to any platform.

Symptoms

Encountering the following java message when starting up the web services.

INFO: JSR 356 WebSocket (Java WebSocket 1.0) support is not available when running on Java 6. To suppress this message, run Tomcat on Java 7, remove the WebSocket JARs from $CATALINA_HOME/lib or add the WebSocketJARs to the tomcat.util.scan.DefaultJarScanner.jarsToSkip property in $CATALINA_BASE/conf/catalina.properties. Note that the deprecated Tomcat 7 WebSocket API will be available.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms