"Page not found" error for some users accessing some LOV pages when using SSO Login (Doc ID 1933199.1)

Last updated on OCTOBER 04, 2016

Applies to:

Oracle Applications Technology Stack - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

Problem description

Problem occurred in Release 12.1.3 instance

When clicking button for search in pop-up window, a new browser window opens, but has error message in the window "page not found" When the error page appears, it comes up immediately. There is no entry in EBS Server access_log for this request

This error only occurs when login using SSO. If the same user using the same PC logins in using AppsLocalLogin.jsp, it shows the search result without any issues.

The issue occurs for other navigation paths, but not for all list of values. Mostly happens for LOV where searching for user names/roles

The issue doesn't happen for all PCs and have so far not been able to identify a pattern. For example, the issue has been seen on a particular PC when using IE8 but on the same PC does not reproduce when using Firefox browser. There are some examples of PCs using IE8 where the issue does not occur. Have also tested other PCs using IE7 and so far have not seen the issue with IE7 either.

The issue is specific to a given PC, in that the user with the failing PC can go to a working PC and login where it will then work (and vice-versa) i.e.
  UserA logs into NotWorking PC with SSO and experiences the reported problem
  UserA logs into NotWorking PC with Local Login and when taking the same steps but does NOT see the reported problem
  UserA logs into Working PC with SSO and when taking the same steps but does NOT see the reported problem

Test Case
One example for a reproducible test case navigation is,
System Administrator -> Workflow -> Administrator Workflow -> Administration -> Vacation rules -> click on "search for user or role" which opens up a new window where in see "page not found"

The URL appearing on the erroring page showing Search and Select List of Values.
  /OA_HTML/cabo/jsps/a.jsp?_t=fredRC&enc=UTF-8&_minWidth=750&_minHeight=550&.......

Are also now getting a Javascript error (since resetting IE8 to default settings)

Webpage error details
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Timestamp: Tue, 2 Jul 2013 14:02:43 UTC
Message: Access is denied.
Line: 18
Char: 1
Code: 0
URI: https://ebsserver.example.com/OA_HTML/cabo/jsps/a.jsp?_t=fredRC........



System Topology
One EBS Middle Tier server behind the load balancer

Cisco Load balancer
  Changed from source ip based stickiness to http cookie but made no difference
  

Additional notes/observations

- Checked browser proxy settings are bypassed for the EBS MT server, so are connecting directly from PC to server. Also "tracert" shows only 1 hop to the EBS server
- Have gone through the settings in "Recommended Browsers for Oracle E-Business Suite Release 12" [ID 389422.1] and cannot identify anything set incorrectly, nor any significant differences between non-working and working PCs
- have had some users with IE9 also report same issue
- tried launching IE8 with add-ons disabled, but still issue occurs

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms