Configuring EBS Application In OEM 12c Errors With oracle.apps.ebs.amp.oms.fwk.ext.exception.AgentInCompatibleException (Doc ID 1935125.1)

Last updated on SEPTEMBER 08, 2016

Applies to:

Application Management Pack for Oracle E-Business Suite - Version 12.1.0.2.0 to 12.1.0.2.0 [Release 12.1]
Information in this document applies to any platform.

Symptoms

On Application Management Pack (AMP) 12.1.0.2.0 version, Auto discovery:

OMS: 12.1.0.3
Agent: 12.1.0.3
EBS Plug-in:12.1.0.2
EBS App: 12.2.3
DB 4 Node RAC (Exadata)

When attempting to discover the E-Business Suite (EBS) Database nodes, the following error is reported in emoms.log:

2014-08-19 00:01:14,012 [EMUI_00_01_10_/console/oam/discovery/diag/discDiagnostics$ctxType=oamFolder] ERROR amputil.AMPHelper error.13 - EMGC Agent version null on host name test01.test.com doesnt match with EMGC version on OMS which is 12.1.0.3.0
2014-08-19 00:01:14,043 [EMUI_00_01_10_/console/oam/discovery/diag/discDiagnostics$ctxType=oamFolder] ERROR amputil.AMPHelper error.18 - Exception in method isOMSAndAgentVersionCompatible
oracle.apps.ebs.amp.oms.fwk.ext.exception.AgentInCompatibleException: OMS version 12.1.0.3.0 is not compatible with agent version on hosts [test02.test.com, test04.test.com, test03.test.com, test02.test.com]


The issue can be reproduced at will with the following steps:
1. Discover the EBS database nodes.

The issue has the following business impact:
Due to this issue, one cannot monitor EBS system from Cloud Control with AMP.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms