Sub Inventory Is Not Populated From Order Management Defaulting Rules When Lines Are Submitted From Service Charges or Depot Repair (Doc ID 1960307.1)

Last updated on APRIL 21, 2017

Applies to:

Oracle Teleservice - Version 12.1.3 and later
Oracle Depot Repair - Version 12.1.3.3 and later
Oracle Field Service - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

On : 12.1.3 version, Charges UI, APIs, and schema

ACTUAL BEHAVIOR
---------------
When Service Request Charges are submitted from Service to OM the subinventory isn't being populated on the sales order lines, even when there are OM Defaulting rules defined to default the subinventory information.
If an identical sales order is manually created directly in Order management, the OM Defaulting rules correctly default the subinventory information.

The same happens with sales orders created from Depot Repair Logistic lines.

EXPECTED BEHAVIOR
-----------------------
Expect that Sub Inventory should be populated using OM Defaulting Rules when sales orders are created from Service/Depot

STEPS
-----------------------
The issue can be reproduced at will with the following steps:

SCENARIO#1:
=========
1. Define OM Defaulting Rules to default the subinventory
2. Create Service Request
3. Create Charge lines and do not enter sub inventory information while doing so
4. Submit the charges
5. On the newly created sales order, when looking on the sales order lines, the subinventory is not populated

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms