Running ojspCompile.pl Fails with Error: "error! ojsp 1.1.x or higher is required, you only have: 01" (Doc ID 1986786.1)

Last updated on OCTOBER 04, 2016

Applies to:

Oracle Applications Technology Stack - Version 12.0 to 12.2 [Release 12.0 to 12.2]
Information in this document applies to any platform.

Symptoms

The ojspCompile.pl located in the $FND_TOP/patch/115/bin directory is used to compile the JSP pages and store cached version used at run-time.

Calling this script either manually or implicitly during patch application the following error is reported fail with following error

error! ojsp 1.1.x or higher is required, you only have: 01

For example:

[user@host bin]$ perl ojspCompile.pl --compile -s 'ddrtest.jsp' --flush --quiet
logfile set: /application/SID/fs2/inst/apps/SID_hostr/logs/appl/rgf/ojsp/ojspc_error.log
starting...(compiling all)

error! ojsp 1.1.x or higher is required, you only have: 01

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms