My Oracle Support Banner

IGISLSAS: After Patch 18964678 Applied: Attempt To Run Subledger Security - Apply Security Program Fails With Error ORA-28113 ORA-00907 (Doc ID 1987246.1)

Last updated on FEBRUARY 26, 2019

Applies to:

Oracle Public Sector Financials (International) - Version 12.1.1 and later
Information in this document applies to any platform.
IGISLSAS module: Subledger Security - Apply Security

Symptoms

OPSF(I) Subledger Security feature shows enabled on your instance

  1. You applied Patch 18964678
  2. You Submit the "Subledger Security - Apply Security" program:
    It fails with the following error in trace file:
    Error information for ORA-28113:
    Logon user : <user>
    Table/View : AR.AR_PAYMENT_SCHEDULES_ALL
    VPD Policy name : <policy>
    Policy function: <function>
    RLS view :
    SELECT "PAYMENT_SCHEDULE_ID","STAGED_DUNNING_LEVEL","DUNNING_LEVEL_OVERRIDE_DATE",.................. FROM "AR"."AR_PAYMENT_SCHEDULES_ALL" "AR_PAYMENT_SCHEDULES_ALL" WHERE ( (payment_schedule_id < 0 OR IGI_SLS_SEC_GROUP = SYS_CONTEXT('IGI','SLS_SECURITY_GROUP'))
    ORA-00907: missing right parenthesis

Changes

 Patch 18964678 was applied

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.