Repair Estimate Charge Price Is Not Calculating Correctly With Advanced Pricing Enabled (Doc ID 1997977.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Depot Repair - Version 12.2.3 and later
Information in this document applies to any platform.

Symptoms

On : 12.2.3 version, Estimate and Actual Charges

ACTUAL BEHAVIOR
---------------
When in the Repair Order form the charge estimate is not being calculated.
This occurs when creating the repair estimate with advanced pricing enabled and
if an all items price list is used.
If you check and un-check 'No Charge' check box then the charge is displayed correctly.

If using an item that is specified in the Price List, then it is working fine.

EXPECTED BEHAVIOR
-----------------------
Expect the estimate charge line to be calculated even it is part of the all item in Price List

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Enable Advanced Pricing in Depot
2. Set up a a specific item in the Price List and another line for all items
3. Go to Repair Estimate tab, add a material line for the specific item and the price is calculated correctly
4. Add another material line for an item that is not specified in the Price List, the charge price is $0


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms