R12: Error : SET_OF_BOOKS_ID is Invalid Ledger ID When Update Suppliers Converted From 11i (Doc ID 2012101.1)

Last updated on AUGUST 09, 2016

Applies to:

Oracle Payables - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

1. DESCRIPTION OF THE LOSS OF FUNCTIONALITY
------------------------------------------------------
In Oracle Payables, when a user attempts to update upgraded suppliers using the supplier page following error occurs:

ERROR
-------
SET_OF_BOOKS_ID is invalid Ledger ID is invalid.


2. BUSINESS IMPACT
----------------------
Due to this issue, users cannot pay supplier on-time. Late payments affect the payment terms established by suppliers and consequently disrupts the business continuity of the organization.


3. STEPS OR EVENTS THAT LEAD TO THE ISSUE OCCURRING
----------------------------------------------------------------
The issue can be reproduced at will with the following steps:

1. Using Payables Manager responsibility

2. Navigate to Suppliers > Entry >

3. Click on Go button to display existing suppliers

4. Click on the Update button next to the selected supplier

5. Attempt to update supplier and the error listed above is displayed.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms