My Oracle Support Banner

DB 9.2.0.6 から10.2.0.3 へアップグレードした後のInvalid の "Owapub" パッケージ (Doc ID 2014432.1)

Last updated on FEBRUARY 14, 2019

適用範囲:

Oracle E-Business Suite Technology Stack - バージョン 11.5.10.2 から 11.5.10.2 [リリース 11.5.10]
この文書の内容はすべてのプラットフォームに適用されます。

現象

11.5.10.2 環境にて:
パッケージ DEBUG_CARTX、OWA_OPT_LOCK と OWA_UTIL をリコンパイルする際に、以下エラーが発生します。

ERROR
Errors for PACKAGE BODY OWAPUB.DEBUG_CARTX:

LINE/COL ERROR
-------- -----------------------------------------------------------------
43/3     PL/SQL: Statement ignored
43/3     PLS-00201: identifier 'SYS.DBMS_PIPE' must be declared
44/3     PL/SQL: Statement ignored
44/3     PLS-00201: identifier 'SYS.DBMS_PIPE' must be declared
46/3     PL/SQL: Statement ignored
46/13    PLS-00201: identifier 'SYS.DBMS_PIPE' must be declared
47/3     PL/SQL: Statement ignored


以下パッケージをリコンパイルする際にも、類似なエラーが発生します:
OWA_OPT_LOCK
OWA_UTIL

 


手順
以下手順にて本事象が再現できます:
1. Oracle Applications (11.5.10.2) のデータベースを 9.2.0.6 から 10.2.0.3 へアップグレードします。
2. こちらの invalid のパッケージを確認します: DEBUG_CARTX, OWA_OPT_LOCK , OWA_UTIL
3. 以下のようにそれぞれのパッケージをリコンパイルします:

SQL> alter package owapub.DEBUG_CARTX compile body;
Warning: Package Body altered with compilation errors.

 

 

 

原因

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


本書の内容
現象
原因
解決策
参照情報

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.