Configurator UI Corrupted After Display Condition is Deleted or Updated

(Doc ID 2067763.1)

Last updated on DECEMBER 18, 2016

Applies to:

Oracle Configurator - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

On : 12.1.3 version, Runtime UI

After removing the Display Condition from a UI element, the following error occurs. This is happening when attempting to launch the model. Even if the Display Condition is added back to the element, the error still occurs. This is happening for just one UI in one model. However, it has happened multiple times.

ERROR
-----------------------
Error
java.lang.RuntimeException

No rule found with id XXXXX in ui xxxxx

java.lang.Runtime.Exception: No rule found with id XXXXX in ui xxxxx
at oracle.apps.cz.dio.ui.UIController.getRuleByID(UiController.java:671)
at oracle.apps.cz.dio.RuntimeNode.getRuleByID(RuntimeNode.java:4056)


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Log in to Oracle Configurator Developer responsibility
2. Open this model in Edit mode from the Repository
3. Navigate to the User Interface tab
4. In the UI, remove a Display Condition from one of the UI elements and Save
5. Generate Logic and Refresh the UI
6. Click on the Test Model button
7. Enter appropriate parameters, including using the modified UI and submit
8. Error occurs.



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms