After Upgrading To Build 31.9, Unable to Access Properties in Published Models (Doc ID 2084634.1)

Last updated on AUGUST 01, 2016

Applies to:

Oracle Configurator - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

On : 12.1.3.31.9 version, Configuration Interface Object

ACTUAL BEHAVIOR
---------------
After upgrading to Configurator build 12.1.3.31.9, it's observed that properties on the Configurator model are not present in the published user interface. Any rules that are associated with a property, or any elements displaying the values of a property, do not function correctly after publication. These features work correctly in using the "Test Model" button in Oracle Configurator Developer. Any extensions written to access these properties additionally will return null values, and will not perform as expected.

EXPECTED BEHAVIOR
-----------------------
It's expected that Configurator will function the same in the published environment as it does through "Test Model". The properties should not be returning null values and associated rules should function as expected.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Configurator developer responsibility
2. Select "Test Model"
3. Notice that model behaves as expected, debugging information indicates properties correctly accessed
4. Navigate to published user interface
5. In the published user interface, properties do not correctly return values


Changes

 Instance was upgraded to 12.1.3.31.9.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms