Lot Starting Number Zeros Lost In WIP: Lot Starting Number Leading Zeros Are Removed When Creating Jobs (Doc ID 2114729.1)

Last updated on MARCH 09, 2016

Applies to:

Oracle Inventory Management - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

Lot Starting Number leading zeros are being removed from the item when creating Jobs.

Setup

What is working
This issue is only found when a lot is assigned via the Discrete Job form.

All other forms tested with auto lot generation work as expected and lot starting number is not affected.

The issue only occurs when starting number begins with zeros (0s).

Expected Behavior
Leading zero should remain in Item

Steps
1) Navigate to Inventory > Items > Organizational Items > Inventory tab

2) Enter a Lot starting number that begins with a zero (0). For example, prefix 92 and starting number 070.
* The issue only occurs when starting number begins with zeros (0s).

3) Navigate to Work in Process (WIP) > Discrete Jobs > Create a job

* See the lot number is assigned to the job automatically upon entering the assembly. At this point the lot is correct with the leading zero.
WIPDJMDF form Nav: WIP >> Discrete >> Discrete Jobs

4) Go Back to Item form (Navigate to Inventory > Items > Organizational Items > Inventory tab)

5) See the starting number has the leading zero removed. Therefore all future jobs will have an incorrect lot number assigned. For example, the previx remains 92 but the starting number is now 71. Expect 071.

Business Impact
As the leading zeros are getting removed when a job is created, it leads to a wrong generation of lot numbers for subsequent lots that are generated using lot form, PO receipts or WIP jobs.
Wrong lots will lead to multiple compliance issue and customer returns.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms