In Oracle Configurator Developer - Model Structure is Blank (Doc ID 2142916.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Configurator Developer - Version 11.5.10.2 and later
Information in this document applies to any platform.

Symptoms

ACTUAL BEHAVIOR
---------------
On Configurator build 12.2.4 as well as 11.5.10, models within Configurator Developer are not displaying their structure. Instead the model details do not display any information on the structure as it will be blank. This was observed with Oracle Database version 12.1.0.2. Issue also impacted features that should have been available in the model repository for the model structure, making it impossible to create new rules. All models were affected on the instance, examples shown occur with a non-BOM model as well as BOM. It's possible to confirm the structure exists in the database, and model reports will still run correctly reporting the expected structure. Through further investigation, it can be observed when enabling a trace and gathering TKPROF output from the database level that no results are returned when the query is called from the application, but calling the same query directly in the database returns expected results.

EXPECTED BEHAVIOR
-----------------------
It's expected the models will display their structure

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Oracle Configurator Developer

2. In the model repository, navigate to a model

3. Navigate to the structure tab

4. Structure does not display, same for all models

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms