Incorrect Quote Selling Price After Re-Configure (Doc ID 2239454.1)

Last updated on MARCH 01, 2017

Applies to:

Oracle Quoting - Version 12.2.5 and later
Information in this document applies to any platform.

Symptoms

On Test: 12.2.5 version, FORMS User Interface

ACTUAL BEHAVIOR
---------------
ASO quote selling price calculation invalid

When you configure a product and click on Finish the control comes back to quote and the product line is added successfully with correct selling price.
You enter the selling price on configurator (UOM is Cost per Thousand).The price gets converted properly on quote to the UOM 'EA' i.e "SELLING_PRICE/1000").

However, when you launch Configurator again but closed without making any changes, the quote was repriced automatically and this time the selling price is not correct.
It divides the selling price on the quote line again with 1000, as the quote line price was already in eaches there was no need to again divide by 1000.

Now, after observing the issue simply saving the Quote will make everything right again.

EXPECTED BEHAVIOR
-----------------------
Correct price should be displayed everytime

STEPS
-----------------------
The issue can be reproduced at will with the following steps:

1. Login to Quoting HTML UI
2. Configure a Model
3. Re-configure without making any changes

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms