Assignment Rule is not Updating a UDA Value in One Attribute Group Based on the Value in a Another Attribute Group (Doc ID 2285348.1)

Last updated on JULY 11, 2017

Applies to:

Oracle Product Hub - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

On :  12.1.3 version, User Defined Attributes

Actual Behavior

After applying two patches (24697699:R12.ENG.C and 23528111:R12.EGO) an assignment rule does not work as expected.
An assignment rule is setup to update a UDA in a second attribute group when the value in a UDA in the first attribute group is changed.
However, when the first UDA is updated, the second UDA is not updated.

Expected Behavior

Expect the assignment rule to update as defined.

Steps

  1. Have two UDA groups AG1 and AG2
  2. Create assignment rule "TEST_ASSIGNMENT_RULE"
    Type=Assignments, Business Entities=Item
    "Show table data when all conditions are met" = Checked
    Seq=1,
    Attribute Groups = "AG1, AG2"
    Attributes "test_2, test_1"
    If, then conditions...
        Set Value of Attribute=AG2.test_2
        If Expression = changed(AG1.test_1)
        Then Expression:
            If Expression=true, Then Expression=AG1.test_1
  3. Update field "test_1" in AG AG1 from NULL values to "X"
    Expect that field "test_2" in AG2 will be set to "X" but it doesn't

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms