Service / Field Service: Charge Line Is Missing For Completed Debrief

(Doc ID 2336381.1)

Last updated on DECEMBER 06, 2017

Applies to:

Oracle Field Service - Version 12.2.4 and later
Oracle Teleservice - Version 12.2.4 and later
Information in this document applies to any platform.

Symptoms

Charge Line is missing for completed Debrief.

After adding 5 lines in Debrief (3 Labor and 2 Expense), one Expense line is missing in the Service form > Charges tab.

When updating the flag to 'No' and re-posting the line, it errors out saying that the line has been already posted to Charges.
Also tried running the Debrief Posting Program. No change.

Expected Behavior:

Service Charges table should have the 5 records.

Steps:

Completed Debrief lines:

Expense tab:

1. SAC = Expense Transaction, Item = SVC HOU, UOM <null>, Qty <null>, Amount = $2750 USD    => Missing in Charges
2. SAC = Expense Transaction, Item = SVC-MIL,  UOM USD   , Qty 704    , Amount => NULL           => OK in Charges

Labor tab:

1. SAC = Labor Transaction  , Item = ASP-LABOR     UOM = HR...
2. SAC = Labor Transaction  , Item = ASP-TRAVEL    UOM = HR...
3. SAC = Labor Transaction  , Item = SVC HR          UOM = HR...

Charges:

1. SAC = Labor Transaction  , Item = SVC HR.... (Labor)
2. SAC = Labor Transaction  , Item = ASP-LABOR (Labor)
3. SAC = Labor Transaction  , Item = ASP-TRAVEL (Labor)
4. SAC = Expense Transaction, Item = SVC-MIL    (Expense)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms