EAM Map Workbench is working, but when teams moves to dynamic services the Map will no longer function

(Doc ID 2391272.1)

Last updated on APRIL 25, 2018

Applies to:

Oracle Enterprise Asset Management - Version 12.2.5 and later
Information in this document applies to any platform.

Symptoms



ACTUAL BEHAVIOR

Currently the Map Workbench works with our GIS server utilizing cached services. Our GIS team is transitioning from cached to dynamic services. After we reconfigure the map in EAM to use the dynamic services the map no longer displays, and we have tried several different tests with no success both on the GIS and Oracle sides. We would like to know if the map was developed only using cached GIS services? If not, what is the correct configuration for dynamic services?

The issue is reproducible, the links are changed to a dynamic service and back to a cached service.

Technically this is working, but when our GIS teams moves to dynamic services the Map will no longer function.

Customer believes this a base product with no customizations.

EXPECTED BEHAVIOR

Expect that the map displays work in dynamic mode

STEPS

The issue can be reproduced at will with the following steps:
Click the Update icon on the Map Manager

Change any one of the Map Layers to a dynamic GIS map service

Now go to Map Workbench and zoom to an area that previously displayed features from the
map layer that was changed in the Map Manager




Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms