Second Asset Search Does Not Yield Results

(Doc ID 2403193.1)

Last updated on JUNE 21, 2018

Applies to:

Oracle Enterprise Asset Management - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

ACTUAL BEHAVIOR

A second search using asset advanced search (and sometimes simple search) yields no results, even though the search criteria is valid and there are assets that meet the criteria.
 
EXPECTED BEHAVIOR

Asset advanced search or simple search should fetch results every time.

STEPS

The issue can be reproduced at will with the following steps:
1. Maintenance Super User Responsibility > Asset Advanced Search Issue
  In advanced search, enter search criteria: Asset Full Description Starts With "xxxxxx", click Go, and results appear

2. Drill into the first asset of the queried results.
  Back out of Asset Detail, then clear the current search criteria.
  Enter new search criteria: Asset Full Description Starts With "yyyyyyy" then Go.
  Although there are assets that meet the search criteria, no results are returned.

3. Exit advanced search, then go to simple search.
  Then return to advanced search.
  Re-enter search criteria : Asset Full Description Starts With "yyyyyyy" then Go

Only after exiting advanced search, returning to advanced search, and then re-entering search criteria fetching the results.

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms