My Oracle Support Banner

Error "ORA-20001: Could not apply invalid crossedition trigger" while upgrading from R12.1 to R12.2 (Doc ID 2751616.1)

Last updated on FEBRUARY 14, 2021

Applies to:

Oracle Financials for India - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

Problem statement
---------------------
While upgrading from R12.1.x to R12.2.10, patch 30399999 failed. 

Error message
-----------------

sqlplus -s APPS/***** @/local/apps/OAT6122/fs1/EBSapps/appl/ad/12.0.0/patch/115/sql/adsqlwrapper.sql '/local/apps/OAT6122/fs1/EBSapps/appl/ad/12.0.0/patch/115/sql/AD_ZD_TABLE_APPLY.sql JAI_REPORTING_ASSOCIATIONS_F1'
Connected.

BEGIN AD_ZD_TABLE.APPLY('JAI_REPORTING_ASSOCIATIONS_F1'); END;

*
ERROR at line 1:
ORA-20001: Could not apply invalid crossedition trigger
"APPS"."JAI_REPORTING_ASSOCIATIONS_F1": PLS-00049: bad bind variable
'NEW.REPORTING_CODE_DESCRIPTION#1'
ORA-06512: at "APPS.AD_ZD", line 26
ORA-06512: at "APPS.AD_ZD_TABLE", line 19
ORA-06512: at "APPS.AD_ZD_TABLE", line 1714
ORA-06512: at line 1



Expected behavior
--------------------
Expects that the patch should be allowed to complete without any error. 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.