My Oracle Support Banner

R12: AP: Supplier HUB API Failing For Batch Loads After Upgrade To 12.2.9, With Error "ORA-20001: APP-SQLAP-10000: ORA-20000: CLL_F255_AP_SUPPLIER_SITES_T1 - ERROR: ORA-04092: cannot ROLLBACK in a trigger" (Doc ID 2791146.1)

Last updated on JULY 12, 2021

Applies to:

Oracle Payables - Version 12.2.9 and later
Information in this document applies to any platform.

Goal

Supplier HUB API failing for batch loads after upgrade to 12.2.9

Supplier update API is failing after processing 250 to 300 records in a batch consistently after recent update of instance to 12.2.9.  Same data is getting processed in 12.1.3 instance without any issues.

API Error :

VENDOR API ERROR :ORA-20001: APP-SQLAP-10000: ORA-20000: CLL_F255_AP_SUPPLIER_SITES_T1 - ERROR: ORA-04092: cannot ROLLBACK in a trigger
ORA-01000: maximum open cursors exceeded
ORA-06512: at "APPS.CLL_F255_UTILS_PKG", line 1041
ORA-06512: at line 1
ORA-06512 in Package AP_VENDOR_PUB_PKG Procedure Update_Vendor_Site_Public


 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.